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Lab 4 

THE BASICS OF NONA, WINCLADA AND TNT 
 

NONA (No Name; Goloboff 1999) [http://www.cladistics.com] is a very efficient PC 
program for parsimony analysis, i.e. searching for shortest trees, (a Macintosh version is also 
available). NONA has a command prompt interface. This program has no maximum limit for the 
number of taxa and/or characters. The trees are internally treated as fully dichotomous, but the 
default option shows only the branches that are unambiguously supported.  It also allows one to 
define the initial tree (“seed”) or to choose a random tree for different strategies in exploring 
tree space. 

 
WINCLADA (Nixon 1999-2002) [http://www.cladistics.com] is a Windows-based 

program that allows one to enter and edit data to be analyzed with NONA. This includes, for 
example, adding and editing names of characters, character states and/or taxa, modifying the 
character coding, deactivating/activating characters, and aligning molecular data by eye. 
Although these functions can be accomplished using a text editor program, WinClada was 
specifically designed for constructing data matrices for cladistic analyses and is much more 
convenient for these purposes. In addition, WinClada allows one to visualize and edit trees 
obtained with NONA. This includes, for example, mapping character states onto a tree, moving 
and/or collapsing branches, choosing alternative rootings and/or optimizations, calculating 
bootstrap values and consensus trees, editing the trees for printing or outputting them to a vector 
graphics program. Finally, WinClada can be used to construct and use multi-entry identification 
keys. 

 
TNT (Goloboff, Farris and Nixon 2000) [http://www.cladistics.com] is a program 

available for Windows, MacOS or Linux.  It has very efficient tree-searching algorithms for 
large data sets of 300 to 500 tax  a.  Parsimony is the only available optimality criterion.  It 
implements many new heuristic search methods, such as the ratchet and sectorial searches. It 
can also be used for tree manipulation and diagnosis.  As it is optimized for large matrices it is 
probably not the best program to use for data sets with fewer taxa. 
 
DOWNLOADING AND UNLOCKING WINCLADA, NONA, AND TNT 
- Make a new folder on the desktop 
- Go to www.cladistics.com/downloads 
- Download all three programs, and some sample data, to your new folder. Here’s how: 

- WinClada: Click on WinClada, scroll to the bottom, click Download WinClada, 
Click WINCLADA.EXE, save to your new folder. 

- Also on this page, download the sample data by clicking: Sample files, compressed 
self-extracting. Save them to your new folder. 

- Nona: Click on Nona, Click on Download Nona, click Pars-win.exe, save Pars-
win.exe to your new folder. 

- TNT: Click TNT, click TNT Download, click TNT, click Win (menu interface), save 
ziptnt.exe to your new folder. 



- WinClada is ready to go, but the other two programs, and the sample data, still need to be 
extracted. Double-click on Pars-win.exe. A command line program will run briefly, then 
your folder will fill up with lots of new programs and other stuff. 

- Do the same for ziptnt.exe 
- Do the same for samples.exe 
- There is still one more step – registering Nona. Go to Start Menu > Programs > Accessories 

> Command Prompt. The command prompt will appear. Change directory to your new 
folder: 

cd Desktop\New Folder 
should work. Now, enter the exact string 

wconvert winona yatasto 
and your name (to register the program to you) or IB 200 A (to register the program with the 
class). 

- Now we’re ready to use the programs. 
 
WINCLADA MATRIX MANIPULATIONS 
 Open WinClada by clicking the WinClada icon in your new folder in the Program menu.  
Once in WinClada, select the “File” menu and then “Open file”.  Open the sample file 
sampldna.ss. Now you can execute as many functions as you wish.  Note that this program has a 
feature to protect the matrix against “typos”, so if you want to actually modify data you have to 
select “Unlocked” under the “Edit” menu. 

WinClada can read and write matrix files in a variety of formats including: *.ss 
(Hennig86/NONA); *.winc (WinClada—an expanded *.ss format that includes WinClada 
preferences and specific commands); *.nex (PAUP/MacClade format); and *gde/*.fst (generic 
DNA sequence formats). NONA can read only *.ss formatted files directly. 

You should explore the functions under each main menu at the top of the screen.  
 

RUNNING NONA FROM WINCLADA 
There are two ways to launch NONA from WinClada: 
1) Select the “Analyze” menu; select “Spawn” then “NONA”.  Select “enter path” (you 

need to tell WinClada where NONA resides on your computer).  Navigate to the NONA icon, 
(WINONA.EXE) select it, and click “Open”, then put the current path as a default. Next, return 
to Analyze – Spawn – NONA – then “Submit Current Matrix”.  WinClada will display a 
“Current Character Settings” window (0 characters should be deactivated, 28 characters should 
be additive, and the average character weight should be 0.857).  Click “yes” and NONA will 
launch.  To exit NONA, type “quit” or “z.”  

2) Select the “Analyze” menu, then select an option (e.g. “Heuristics”) and enter the 
appropriate values.  NONA will be spawned and proceed with an analysis as instructed by 
WinClada. When the analysis is complete, NONA will close and return the results to WinClada 
automatically, displaying the output trees in the tree-viewing (“winClados”) window. To change 
from the tree window to the matrix window choose the “Interface” menu and select “winDada”.  
Once you understand how to enter and exit NONA, submit your data to NONA.  Select the 
“Analyze” menu, then “Spawn”, “NONA”, and “Submit Current Matrix.”  Once in NONA, type 
the following commands (each command should be followed by a semicolon “;” and the <enter> 
key.  

Type: 
help; This will display a list of all the commands and arguments. 



whennig; (or “w;”) at the command line. This will calculate a Wagner tree. You will be 
presented with information about the tree (its length) but you will not see the tree until you type: 

tplot; (or “tp;”)The tree should then be printed to the screen.  This tree, obtained with 
the command “whennig;”, is not necessarily the shortest tree.  In order to save the tree to a file, 
use the command: 

sv* my.tre sv/; (where “my.tre” is the name of the file, e.g. “brent.tre”).   
Now exit NONA (type “z;”) and return to WinClada. 

 
WINCLADA TREE MANIPULATIONS 

In WinClada, open the tree you saved by going to the “File” menu and selecting “Open 
Tree file.” Find the file and open it. The tree will appear in the tree window (winClados) of 
WinClada. 

1. The spacing and appearance of the branches can be changed with the function keys: 
F2 and <shift> F2 change the thickness of the branches 
F3 and <shift> F3 change the horizontal spacing 
F4 and <shift> F4 change the vertical spacing 

2. The arrow keys can be used to move the tree around the screen (note: the tree is treated 
as a graphics object—not a text object—so the up arrow moves the tree up the screen, not 
down—as you would expect if you were scrolling in a text editor). 

3. Practice changing the form of the tree; go to “View”, select “Tree style” and then 
select a tree style, or use the ninth through thirteenth buttons (from the left) above the tree 
window to change the tree style. To change the taxon font, go to “View”, select “Fonts”, and 
then “Taxon font”. 

4. Look under the diagnoser menu and investigate the distribution of characters on the 
tree. 

5. Finally, toggle back and forth between the winClados and winDada windows by 
selecting the “Interface” menu then click “WinDada” or “WinClados”, as appropriate. 

 
The Parsimony Ratchet 

 
Most real data matrices have too many taxa (i.e. more than about 25 taxa) to be analyzed 

by exact methods therefore a search for the most parsimonious trees must be conducted. In many 
cases the shortest trees—or more precisely the trees that we think are the shortest—are easily 
located. In other instances the shortest trees are difficult to locate. It is not possible to predict, 
from the matrix, the ease in which the shortest trees will be found (if they ever will), or ascertain 
that one has found the shortest trees. The only criterion that can be used is reproducibility: if 
numerous searches, with different search parameters, of the matrix produce the same result(s) 
then one must assume that the shortest trees—or at least the shortest trees that will ever be 
found—have been located. Effective search parameter must be determined empirically.  

 
In a “conventional” search a Wagner tree (or some other starting tree) is calculated and 

then a branch swapping algorithm (of some kind) is applied to the tree. Usually multiple starting 
points are utilized to minimize the possibility of becoming stuck in local optimal (or sub–optimal) 
portions of “tree space”.  The search stops when all the trees retained in memory have been 
swapped and no shorter trees have been found.  Given a finite amount of time, the best way to 
maximize the exploration of tree space is to limit the number of trees retained during branch 



swapping.  In most cases only the shortest trees found during the first phase are swapped, but in 
some cases some percentage of the shortest length trees are swapped. 

 
Nixon (1999) proposed a new tree search method called the parsimony Ratchet (Nixon 

1999). The ratchet can be viewed as the application of a Markov Chain to tree search.  The 
ratchet procedure starts by searching for the best tree.  Then it resamples the data with 
replacement or jacknifes it and randomly constrains some nodes.  It searches tree space again 
with the newly defined parameters.  It returns to the original settings and repeats the whole 
process multiple times. By reweighting the characters the ratchet produces a more radical 
search of tree space, which is still constrained by the data.   
  
PARSIMONY RATCHET EXERCISE 
 
1. Open the sampldna.ss data matrix in WinClada. 
 
2. Choose “Ratchet (Island Hopper)” under the “Analyze” menu.  
 
3. Set the number of iterations to 200; the number of trees to hold per iteration to 1; the number 
of characters to sample to 7; the stem name to “yourname”; keep the default ambiguity setting; 
and set the level or random constraints to 10%.  
 
4. Click on “Island Hop”. WinClada will spawn NONA and the shortest ratchet trees will appear 
in the WinClada tree window. 

 
TNT 

 
 TNT can do a number of different heuristic searches in addition to the standard ones 
included in most phylogeny packages.  The more advanced searches are included under new 
technology searches, and can be used alone or in combination. 
 Sectorial- Explores rearrangements of local clades while leaving the rest of the tree 
unmodified.  It does this successively for different clades chosen at random. 
 Ratchet- The same as described above 
 Drifting- Like the ratchet it alternates between normal searches and more liberal ones.  
Instead of reweighting the characters during the liberal searches it accepts new trees based on 
the fit between the new tree and those already in memory.  
 Tree Fusion- Mixes trees that are already in memory making new synergistic trees.  If the 
trees come from different searches then the scores can be improved quickly and drastically. 
 

Open TNT by clicking the TNT icon in the ib200a folder in the startup menu.  Select the 
“file” menu and then “open input file”.  Open the “example.tnt” file.  TNT is actually capable of 
reading a number of file formats including nexus, but this file are specifically formatted for TNT. 
 Pull down the “Analyze” menu and select “New technology search”.  Select the ratchet 
and deselect the other options.  Select the ratchet settings and change the number of iterations to 
15.  Hit OK and then Search.  It will run your analysis very quickly.  It will give you some 
statistics on the best tree it found. 



Pull down the trees menu and select view.  Since you got multiple trees from this analysis 
you need to generate a consensus tree.  Pull down the trees menu and select consensus.  Then 
select majority rule and hit OK.  This is your consensus tree.  Hit the escape key to return to the 
main screen. 
 Try other methods under the new technology search.  You can use them alone or in 
combination.  Which combination of methods finds the shortest tree?  How many shortest trees 
did it find?  How long did it take?  Does changing the settings change the result?  Do the same 
settings always find the same trees? 
  

KIP’S EXCERCISES 
 

Several of the excerises that Kip handed out in class require WinClada (actually, if you look at 
the note at the end of the handout, it looks like the handout was originally written by Kevin 
Nixon, who also wrote WinClada.) Feel free to take some time to do these exercises now if you 
like.  
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